dotfiles

configuration files for shell, text editor, graphical environment, etc.
git clone git://src.adamsgaard.dk/dotfiles # fast
git clone https://src.adamsgaard.dk/dotfiles.git # slow
Log | Files | Refs | README | LICENSE Back to index

Makefile (861B)


      1 .POSIX:
      2 VERSION = 2.1.7
      3 
      4 ncview-$(VERSION)/ncview: ncview-$(VERSION)/Makefile
      5 	make -C ncview-$(VERSION)
      6 
      7 ncview-$(VERSION)/Makefile: ncview-$(VERSION)
      8 	export LD_LIBRARY_PATH=/usr/local/lib:$${LD_LIBRARY_PATH}
      9 	if ! test -r ncview-$(VERSION)/configure-bck; then \
     10 		cp ncview-$(VERSION)/configure{,-bck}; fi
     11 	cp ncview-$(VERSION)/configure{-bck,}
     12 	printf '5828,5829d\ni\necho\n.\nw\nq\n' | ed -s ncview-$(VERSION)/configure
     13 	cd ncview-$(VERSION) && ./configure --prefix=/usr/local
     14 	touch $@
     15 
     16 ncview-$(VERSION): ncview-$(VERSION).tar.gz
     17 	tar xvfz ncview-$(VERSION).tar.gz
     18 
     19 ncview-$(VERSION).tar.gz:
     20 	ftp ftp://cirrus.ucsd.edu/pub/ncview/ncview-2.1.7.tar.gz
     21 
     22 clean:
     23 	rm -rf ncview-$(VERSION)
     24 	rm -f ncview-$(VERSION).tar.gz
     25 
     26 install: ncview-$(VERSION)/ncview
     27 	make -C ncview-$(VERSION) install
     28 
     29 install-deps:
     30 	pkg_add udunits
     31 
     32 .PHONY: clean install install-deps